Page 1 of 1

[RESOLVED] Missing Cinematics from Main Menu

Posted: Mon Mar 13, 2023 8:42 pm
by Manny
Today I noticed that for some odd reason I only have the game cinematics for Act I - III.

Any idea how to restore these? I have 3x Matriarchs and 1x Patriarch on this save, and I can seem to recall not many weeks ago I had all the cinematics listed in there.

I have tried 'resetting' my Cactus for this instance, but no change.

Re: Missing Cinematics from Main Menu

Posted: Mon Mar 13, 2023 9:00 pm
by fearedbliss
Hmm interesting. I'm not sure about that. Do you know if the MPQs you are using are the full ones from the full installation? Or are you using the 1.12+ MPQs?

From my understanding of my skip intro cinematics patch, it should only skip the cinematics when the game starts up, so there shouldn't be anything affecting the cinematics as part of character quest transitions. Given that you already have 3 of the cinematics using Singling, i would say that Singling isn't the issue. If it were to affect the cinematics I would think all of them would be broken. I'm also thinking something may be happening if you let's say, transferred characters from one computer to another. I don't remember if there are any registry keys specific to quest cinematics. I don't remember any though.

Could you try getting a character to complete the Act 3 quest while you are in full screen? You may need to not use cnc-ddraw if it doesn't show the cinematics, but you could try. Basically I'm trying to see if you see the Act 4 cinematics. I can also try and reproduce it by using hero editor to speed things up. I'll let you know if I can reproduce it.

Re: Missing Cinematics from Main Menu

Posted: Tue Mar 14, 2023 7:22 am
by Manny
I used the 1.14b digital installers from BNET, so the MPQ's are those. BTW, I just ran through those installers again, and I noted that nowhere does it give the option to do a "full install". Perhaps I should grab the CD's from my Battle Chest and install from there for comparison.

This entire Cactus folder and it's characters were indeed moved from another computer a few months ago, so your hunch is correct. That leads me to believe that there is a registry key associated with cinematics, but which one that might be is a mystery to me. Is it possible that one gets generated after completing a difficulty?

Thanks for looking into things, and yeah, I don't think this has anything to do with Singling at all. ;)

Re: Missing Cinematics from Main Menu

Posted: Tue Mar 14, 2023 8:19 am
by fearedbliss
@Manny Alright I figured it out, and yea, it's related to switching computers (and thus a "fresh install"). The characters don't really matter since we can unlock all cinematics without them if you know the registry key.

Blizzard North was clever and I love them lol. I'm sure they did this so it wasn't too easy to unlock all of the cinematics using common sense, however, the answer is right before our eyes. So essentially what they did was use a registry key in a way that isn't immediate obvious to the uninitiated haha. I did all of this in a fresh Windows 10 VM using the 1.14b installer (to replicate what you have, but should work for the original CDs, I haven't tested that though).

When you first open D2 for the first time, you'll have this registry key automatically created for you:

Code: Select all

Location: Computer\HKEY_CURRENT_USER\SOFTWARE\Blizzard Entertainment\Diablo II
Key Name: Aux
Type: REG_SZ (String Value)
Key Value:
When the value ends in "34", it will only show you the first cinematic (The Sister's Lament). Which makes sense since you just installed the game for the first time and haven't played it yet. As you progress through the game, the ending IP will change which reflects what cinematics you can see. So for example, when we finish the Act 4 quest and talk to Tyrael to go to Harrogath for the first time, the IP will change to "", which includes all cinematics up to "Search for Baal". The funny thing is, after I killed baal for quest, I looked at the IP again, and it went from "178" to "35", which is funny because remember, "34" was when we first installed the game. So if you literally bump it up by 1 digit it will unlock all of them. Almost coming back full circle. That's funny.

So in summary:

Code: Select all (Only First Cinematic - "The Sister's Lament") (Up To "Search For Baal") (Up To "Destruction's End")
Go ahead and create that registry key and let me know if it works for you.

Re: Missing Cinematics from Main Menu

Posted: Tue Mar 14, 2023 8:35 am
by Manny
Dude! This just made my day. I have always been perplexed by that "Aux" registry key. Man, they were some sneaky condors fa sho, lol. But alas, I love them too. :D

Modifying that last digit from 34 to 35 just did the trick. Thanks for figuring this out!

Re: Missing Cinematics from Main Menu

Posted: Tue Mar 14, 2023 8:36 am
by fearedbliss
Haha nice! I'm glad it worked for you. And pun intended for them being "Sneaky Condors" ;D. If you know, you know.

Re: [RESOLVED] Missing Cinematics from Main Menu

Posted: Wed Mar 15, 2023 9:48 am
by fearedbliss
I uploaded a new video showing the cinematic unlock fix. I also tested this on the original 1.00 / 1.07 files and it also worked. So it doesn't matter how you installed Diablo II.

Re: [RESOLVED] Missing Cinematics from Main Menu

Posted: Wed Mar 15, 2023 3:49 pm
by Manny
Hell yeah bro. I'm glad this turned into more knowledge for the community and a nifty video to boot! :D