[RESOLVED] Main menu mouse lag & is there any way to improve ghosting?

Status
Not open for further replies.

Ülthör

New member
Joined
Apr 9, 2023
Messages
23
Points
0
Hello wanderers,

I’ve got the common issue of mouse lag in the main menu, and noticed there wasn’t a topic for it. Hopefully we can find a common fix for anyone with the same issue. I heard fearedbliss say in the tutorial that Cnc-Ddraw will stop this happening but I’m convinced mine is working. I even deleted all d2 files and made a fresh download from the blizzard site, and re installed cactus to make sure I had a perfect install, but thats the only thing I’ve tried to fix the menu lag so far.

One other thing I’d just like to ask about/discuss is the rampant ghosting in diablo II, that I don’t think can be fixed but I’m asking anyway. Cnc-ddraw and Vsync make the game look better than it has since 2002, but I can’t help but think just how much better the game would look and feel when moving around without the ghosting making everything look like you’re drunk in GTA. Is there any way to improve it?

If you visit the Arcane Sanctuary, stand still and look at the stars moving you get a ghosting test similar to the standard https://www.testufo.com/ghosting
 
Hey @Ülthör,

[mention]Erayz[/mention] Had this issue recently and I replied about it here: https://themovingcaravan.com/viewtopic.php?p=818#p818

This is documented in Singling’s notes section and you are correct that using `cnc-ddraw` fixes the issue. I’m also using cnc-ddraw on Windows 10 in versions below 1.10 and have no lag after using it. As I mentioned to [mention]Erayz[/mention], if you press [Alt + Enter] and your D2 window doesn’t flip between full screen / window mode (depending if you haven’t modified your ddraw.ini config), then that means cnc-ddraw is actually not working.

This was my previous post about it in the above link:

On another note:

1. What Windows version are you using?
2. Did you try out my Alt + Enter test notes from above? If it doesn’t flip between Full Screen / Window Mode, then cnc-ddraw isn’t running.
3. As @Manny mentioned above, if cnc-ddraw isn’t automatically picked up, and you’ve already used the D2VidTst.exe from a pre 1.14 version (or even if you didn’t), you should nuke that registry path completely (The \"Diablo II/VideoConfig\" key).

Lastly, I would highly recommend watching my \"How to play any version of Diablo II with Cactus\" which goes into everything step by step from a fresh installation. You’ll be able to get a better understanding of how it works and if there are any things you may have missed. It seems you are almost there.

https://youtu.be/kAFfc-kjTxE

The alternate solution is to remove the CPU fix for the main menu by replacing the D2Win.dll for your particular version of the game with the Stock D2Win.dll. The original dlls are also included in Singling. Make sure once you replace the dll in your Platforms directory, that you click the \"Reset\" button in Cactus before running the game.

RE: The ghosting issue, I’m not sure about that but given the 20 years I’ve been playing the game, there are a lot of things that my eyes have gotten used to and don’t really bother me haha.
 
I forgot to mention that there is also this documentation in Cactus’ Renderers Page: https://github.com/fearedbliss/Cactus/blob/main/README-RENDERERS.md#cnc-ddraw
 
I see it does only happen on the singling patches.

I think I’ll keep the laggy menu and singling features, it really hasn’t effected anything for me so I don’t mind the exchange

I’ve devoured that video, watched every section of it a couple of times over to make sure I got it perfect :)
 
[mention]Ülthör[/mention] Singling’s D2Win.dll at the moment only fixes the Main Menu CPU issue so reverting that file won’t cause you to lose any other features (You’ll still have the CPU fix working in-game since that’s done in another file). However, I do think something is off on your machine with cnc-ddraw, and I don’t think it’s properly being used.

- What version of Windows are you running?
- Are you launching D2 with any flags?
- Which D2 version are you launching?
- Did the [Alt + Enter] test work?
- Is ddraw.ini, ddraw.dll, and the Shaders folder located in the D2 root directory? It should not be inside the Platform folder.
- What does your registry’s VideoConfig section say? (As mentioned in the documentation. Ideally that folder should be deleted. You can try it again after, or you can create it with that single Render key. Check out the documentation for exact instructions).
 
I came to the same conclusion, I think only part of the cnc-ddraw is working, such as the shaders. The ddraw.ini seems to be fully functional for what I’ve tried changing.

windows 10
no flags
1.00, 1.03 and 1.05b so far
Yes the alt enter test works,
Yes the ini file is there and I’ve been editing it a bit, fairly familiar with the layout of the file even (haven’t tried out any other of the cool filters yet :) )
I did delete the registry key, but did not create a new one in any special way, so I’ll get on that next
 
Hmm weird and interesting. When you say \"main menu mouse lag\" do you mean just the cursor is lagging or the entire main menu? Normally it’s the entire menu that lags, not just the mouse.

I’m guessing 1.03 is working fine since there is no Singling for that version?

Also, could you try reverting the D2Win.dll in the Platforms folder and then clicking Reset and re-running that version? That should fix it. If it doesn’t, then something else is going on (but I believe this will work). The original D2Win.dll will be in the Singling/Stock folder for the particular version in question.
 
[mention]Ülthör[/mention]

Hey, you should also try adjusting your mouse sensitivity in Windows. If the mouse sensitivity/DPI is too high it will also cause the main menu lag that you describe (even with Singling enabled). I’ve had this happen to me with modern gaming mice. If you’re using a gaming mouse it may also have it’s own app/settings config that will usurp the Windows setting, so be aware of that.
 
[mention]Ülthör[/mention] [mention]Manny[/mention] I have a new fix for the Main Menu (D2Win.dll) that should solve this problem once and for all. Once the fix is in, the fix will just work and you won’t even need cnc-ddraw anymore as a workaround either. I’m doing some final testing and clean ups and then I’ll get it ready for release. I should be releasing it a little later today. Stay tune.
 
fearedbliss said:
@Ülthör @Manny I have a new fix for the Main Menu (D2Win.dll) that should solve this problem once and for all. Once the fix is in, the fix will just work and you won’t even need cnc-ddraw anymore as a workaround either. I’m doing some final testing and clean ups and then I’ll get it ready for release. I should be releasing it a little later today. Stay tune.

Awesome, I haven’t even tried using the old ones yet so I’ll just hang on for that, great move
 
[mention]Ülthör[/mention] I’ve released the fixes and you can read more about it here: https://themovingcaravan.com/viewtopic.php?t=200

Let me know if it works for you :).
 
fearedbliss said:
@Ülthör @Manny I have a new fix for the Main Menu (D2Win.dll) that should solve this problem once and for all. Once the fix is in, the fix will just work and you won’t even need cnc-ddraw anymore as a workaround either. I’m doing some final testing and clean ups and then I’ll get it ready for release. I should be releasing it a little later today. Stay tune.

Nice! :D
 
[mention]Manny[/mention] The published changes includes the fixes for the Main Menu in D2Win.dll, and also I’ve optimized the CPU fix for In Game as well which is part of other stuff in D2Client.dll. That optimization was applied to all the versions including 1.10. make sure you update all of your Singling files. I added some instructions for that in the release post, just in case.
 
fearedbliss said:
@Manny The published changes includes the fixes in D2Win.dll, and also I’ve optimized the CPU fix for in game as well which is part of other changes in D2Client.dll. that optimization was applied to all the versions including 1.10. make sure you update all of your Singling files. I added some instructions for that in the release post, just in case.

Thank you [mention]fearedbliss[/mention]!

I just finished updating all my platforms (1.05b, 1.07, 1.09b, & 1.10) with the new Singling files. I like to keep my Cactus fresh with the latest & greatest ;)
 
[mention]Manny[/mention] Haha nice. If you wanna test if it works, you can run D2 with -w flag which will cause it to not use cnc-ddraw and will use the old d2 renderer. The game should not lag in the main menu. You can remove the -w when you are done. Let me know if you experience any weirdness in general.
 
Haha. Yup [mention]Ülthör[/mention], I fixed it for 1.00-1.09b. And also included some slight cpu enhancements for 1.10 as well.
 
fearedbliss said:
@Manny Haha nice. If you wanna test if it works, you can run D2 with -w flag which will cause it to not use cnc-ddraw and will use the old d2 renderer. The game should not lag in the main menu. You can remove the -w when you are done. Let me know if you experience any weirdness in general.

Tried testing it with the -w flag and it worked perfectly without any lag. Good to know the fix works even without cnc-ddraw, but I will continue to use that for the nice config & shader support. Anyways, awesome work on this! Thanks again. ;)
 
Status
Not open for further replies.
Back
Top